読者です 読者をやめる 読者になる 読者になる

インドさんの甘口ポエムブログ

カレーのこととか、プログラミングのこととか。

sublime text2のPackage Controlが使えなくなっていたので直したメモ

sublime text2便利! 便利なので沢山使ってます。

Package Controllっていうプラグインを入れたら vimのvundleよろしく、プラグインを一括管理出来るのも便利だと思ってます。

しばらくプラグイン入れてなかったので新しく入れようと、「Package Controll: Install Package」してみたけど応答なし・・・。(あれ)

view/Show Console してチェックすると、

ValueError: invalid literal for int() with base 10: '0-beta'

というエラーメッセージが。調べてみると、githubのissueに行き当たりました。

https://github.com/wbond/sublime_package_control/issues/201

なので、もう一回コンソールで↓を入力して、入れなおしたら動きました。

import urllib2,os; pf='Package Control.sublime-package'; ipp=sublime.installed_packages_path(); os.makedirs(ipp) if not os.path.exists(ipp) else None; urllib2.install_opener(urllib2.build_opener(urllib2.ProxyHandler())); open(os.path.join(ipp,pf),'wb').write(urllib2.urlopen('http://sublime.wbond.net/'+pf.replace(' ','%20')).read()); print 'Please restart Sublime Text to finish installation'